【e203】gcc 版本问题

2020-05-14 15:31:42
4
504

我从 riscv 的 github 官网 https://github.com/riscv/riscv-gnu-toolchain 下载的源码编译的 gcc,配合 e023 下面的 sirv-e-sdk,编译出的 hello world 串口没有打印信息,但是换成 https://github.com/ilg-archived/riscv-none-gcc 就可以打印了。

请问是源码编译 gcc 的时候需要特别设什么吗?

用户评论 (4)
  • Lynn Peng

    2020-08-26 15:28:27 Lynn Peng 1#

     我也遇到了一样的问题,想请问楼主解决了吗?找到是什么原因造成的吗?

  • 冯兵

    2020-06-04 17:17:18 冯兵 2#

    不清楚gcc版本需要最低需要多少合适?我虚拟机上版本是4.4.7,编译spike报错“-std=c++11”.

  • 领主文

    2020-05-16 08:58:36 领主文 3#

    建议直接用官方的工具链吧,可能有一些根据SDK来的修改,或者其他的修改。自己做的编译器就自己整编译指令或者自己做个SDK用吧。

  • Qian?

    2020-05-14 15:53:05 Qian? 4#

    编译出来的 gcc 的版本信息如下


关注我们

微信扫码登录 点击刷新二维码